How can we improve the PI Server?

Eliminate the 2-cell-wide blank border around PI Builder data

When I import data using PI Builder, I usually want to filter the data and create calculated columns, but these prove to be more painful than necessary.

If I put filters on the columns containing PI Builder data and then click on the filter dropdown arrow, every column will contain "(Blanks)" as an entry because the 2 blank rows underneath the PI Builder data are included as part of the PI Builder data. This happens because PI Builder modified these rows during the import.

Calculated columns are useful to modify the values in an existing column. For the fill-down to work when you double-click on the fill handle (bottom right corner of a selected cell), the calculated column must be directly beside the PI Builder data. However, this doesn't work because the 2 columns to the right of the PI Builder data are formatted as text, so any formula that you write in them will be treated as text. It is a pain to always eliminate the text formatting or delete the columns.

In both cases, please ensure that PI Builder does not modify more cells than it needs to.

2 votes
Sign in Sign in with OSIsoft
Signed in as (Sign out)

We’ll send you updates on this idea

Kenneth Barber shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

6 comments

Sign in Sign in with OSIsoft
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base

Posted ideas will have one of the following statuses.
Full definition of these statuses can be found on the Home Page.
No status
NEEDS MORE DISCUSSION
RESEARCHING/EVALUATING
DECLINED
PLANNED
STARTED/IN DEVELOPMENT
IN BETA
COMPLETED